Julie B-Log

A Belgian in London’s blog ou le blog d’une belge à Londres

Twitter Premium Accounts: did you fall for it?

Posted on | March 20, 2009 | 1 Comment

Twitter

These last hours, a satirical blog (BBspot), though described some years ago as “world’s best tech humour site” by The Register, fooled credulous journalists and bloggers and worried the Twittersphere.

The hoax: Twitter co-founder and CEO Evan Williams has announced the launch of Twitter premium Accounts. Williams explained that many users have expressed the willingness to pay for accounts and that now they give them that opportunity but stressed that free accounts will still be available to all users, and that only those wanting more services would have to pay.

Brian Briggs, the blogpost author, goes even further and detailed the 4 types of accounts.
While up to now, the information could have been credible (as Twitter, since its creation, tries to find itself a business model), the possibility of being followed by a celebrity or the concept of a Twitter Concierge who will tweet for you while you are asleep or busy (and more) were a bit too much…

 BBspot post here

Comments

One Response to “Twitter Premium Accounts: did you fall for it?”

  1. déguisement disco
    November 25th, 2009 @ 3:38 am

    Reste maintenant à savoir quels critères seront utilisés pour définit un compte comme “professionnel” et à déterminer le juste prix d’un tel service. Car si quelques dizaines de dollars par mois est une somme ridicule pour les grands acteurs, elle pourrait effrayer les petits e-commerçants désireux de se lancer sur Twitter. Une solution résiderait peut être dans un montant proportionnel au nombre de followers ?

Leave a Reply





  • About

    Welcome! Bienvenue!
    London, films, music, books, languages but also Public Relations, Social Media, web 2.0, blogging... That’s what this bilingual (English-French) blog is all about!
  • twitter / juliebodart
  • My cv

    CV Julie Bodart
  • RSS

  • Random Flickr

    Roy Tanck's Flickr Widget requires Flash Player 9 or better.

    Get this widget at roytanck.com
?>